Board logo

标题: AIX 7.1版本中图形化安装IBM Installation Manager失败分析与解决 [打印本页]

作者: YuLimin    时间: 2018-7-3 01:35     标题: AIX 7.1版本中图形化安装IBM Installation Manager失败分析与解决

继之前碰到的《WAS 8.5在AIX上无法启动图形化概要管理工具WCT或PMT之解》之后
http://www.java2class.net/bbs/viewthread.php?tid=231

也会在AIX 7.1版本中安装IBM Installation Manager时需要图形时碰到相关的问题
检查版本
# oslevel -s
7100-05-02-1810

比如:
错误1:
# rpm -ivh libjpeg-6b-6.aix5.1.ppc.rpm
Preparing...                          ################################# [100%]
        file /opt/freeware/64 from install of libjpeg-6b-6.ppc conflicts with file from package expat-2.0.1-1.ppc
        file /opt/freeware/64/lib from install of libjpeg-6b-6.ppc conflicts with file from package expat-2.0.1-1.ppc
        file /opt/freeware/64 from install of libjpeg-6b-6.ppc conflicts with file from package zlib-1.2.3-3.ppc
        file /opt/freeware/64/lib from install of libjpeg-6b-6.ppc conflicts with file from package zlib-1.2.3-3.ppc
        file /opt/freeware/64 from install of libjpeg-6b-6.ppc conflicts with file from package fontconfig-2.4.2-1.ppc
        file /opt/freeware/64/lib from install of libjpeg-6b-6.ppc conflicts with file from package fontconfig-2.4.2-1.ppc
需要更新库版本为libjpeg-6b-7.aix6.1.ppc.rpm
下载地址:ftp://public.dhe.ibm.com/aix/fre ... 6b-7.aix6.1.ppc.rpm
安装之:
# rpm -ihv libjpeg-6b-7.aix6.1.ppc.rpm
Preparing...                          ################################# [100%]
Updating / installing...
   1:libjpeg-6b-7                     ################################# [100%]

错误2:
# rpm -ivh xft-2.1.6-5.aix5.1.ppc.rpm
Preparing...                          ################################# [100%]
Updating / installing...
   1:xft-2.1.6-5                      ################################# [100%]
error: unpacking of archive failed: cpio: Bad magic
error: xft-2.1.6-5.ppc: install failed
更新至:xft-2.1.6-5.aix6.1.ppc.rpm
下载链接:ftp://public.dhe.ibm.com/aix/fre ... .6-5.aix6.1.ppc.rpm
安装之:
# rpm -ihv xft-2.1.6-5.aix6.1.ppc.rpm
Preparing...                          ################################# [100%]
Updating / installing...
   1:xft-2.1.6-5                      ################################# [100%]

错误3:
# rpm -ivh gtk2-2.10.6-4.aix5.2.ppc.rpm
error: Failed dependencies:
        libjpeg is needed by gtk2-2.10.6-4.ppc
        pango >= 1.14.5 is needed by gtk2-2.10.6-4.ppc
        libjpeg.a(libjpeg.so.62) is needed by gtk2-2.10.6-4.ppc
        libpango-1.0.a(libpango-1.0.so.0) is needed by gtk2-2.10.6-4.ppc
        libpangocairo-1.0.a(libpangocairo-1.0.so.0) is needed by gtk2-2.10.6-4.ppc
更新至:gtk2-2.10.6-5.aix5.2.ppc.rpm
下载链接:ftp://public.dhe.ibm.com/aix/fre ... .6-5.aix5.2.ppc.rpm
安装之:
# rpm -ihv gtk2-2.10.6-5.aix5.2.ppc.rpm
Preparing...                          ################################# [100%]
Updating / installing...
   1:gtk2-2.10.6-5                    ################################# [100%]

总结:其他的库也可以更新到最新的版本!并一一安装即可。

[ 本帖最后由 YuLimin 于 2018-7-3 01:36 编辑 ]




欢迎光临 Java2Class (http://www.java2class.net/bbs/) Powered by Discuz! 6.1.0